dbKoda hangs on first screen

Patrick Kaeding shared this question 8 months ago
Answered

I am trying to get started with dbKoda, but when I open it, it seems to hang on the loading screen forever. I opened the devtools, but I don't see any errors on the console. I also tried refreshing both the UI and the controller, while I had the console open, but still did not get any errors.

I tried exiting dbKoda, then `rm-rf ~/.dbKoda` and re-opening dbKoda, but it is still stuck.

Are there any other places to look for error logs? Or any other things to try?

Comments (4)

photo
1

Hi Patrick,

Sorry to hear you are having troubles with dbKoda. It's not a problem we see very often, and when we do see it, it's usually the result of a problem in our "statestore" which is in the .dbKoda directory. So you've been doing every thing right so far. The only think I would do in addition is make sure that there are no dbKoda processes running in the background - eg, make sure that you killed dbKoda completely before removing the .dbKoda directory and relaunching.

The location of the logs are OS dependent.

On MacOS: ~/Library/Application\ Support/dbKoda/logs

On Windows: c:\Users\username\AppData\Roaming\dbKoda\logs

On Linux: ~/.config/dbKoda/logs

Feel free to forward those logs to us if you would like.

Can I ask what OS and release of the OS you are running?

Also did you install from the 0.9 binary on the website, a nightly build or did you build from source? We are running nightly builds and launching from source internally, but the website binary is the most stable build we have.

Let us know if you can how you get on - we'll do whatever we can to get you up and running

Regards,

Guy from dbKoda

photo
1

Hi Guy


Thanks for the quick reply!

I'm on Mac OS 10.11.6. Just now, I made sure there were no dbKoda processes running, and I `rm-rf ~/.dbKoda`, and started dbKoda, and I still get the same result.

I don't see any errors logged in either the app or controller logs in `~/Library/Application\ Support/dbKoda/logs`, but I did notice this: `dbKoda Controller is ready at localhost:3030`. I have another application listening on localhost:3030. I tried killing that, and restarting dbKoda, and I see the 'Hi There' message, so I think that was the cause of my problem.

However, I need that other process listening on 3030 in order to do what I need to do. Is it possible to change the port of dbKoda? Ideally, it would maybe find its own open port, or even better, listen on a domain socket, or something?

Thanks for your help, I will poke around in dbKoda now :)

photo
1

Hey Patrick,

Excellent debugging! We did fix the 3030 conflict issue in the current code line. It should be fixed in this build: https://github.com/SouthbankSoftware/dbkoda/releases/tag/untagged-db36a8e18221899ab664 - This is a 0.9.0 branch with a few bug fixes. It's been smoke tested but not widely distributed, but I think it should find a free port rather than failing if 3030 is taken.


Our next major release is due on March 19th and will include this fix.

Thanks for trying dbKoda and please do let us know if there are any further problems or if you have any feature suggestions!


Thanks again,


Guy

photo
1

Hey Patrick,


Just letting you know the new version of dbKoda is out and the fix for this issue is in there, you can grab the latest version on dbkoda.com along with the full release notes for 0.10. Thanks again for helping us improve the product!


Kind Regards,Michael.