Option to disable Authentication

Tony shared this question 1 year ago
Answered

Hi. We use a DB that doesn't have a username/password set. I know this might seem like an unusual and unwanted condition, but it's a development environment.

Using the connection gui, I'm unable to create a connection as it expects a username and password. I found that if I edit the stateStore.json, and set authentication to false, then I can connect.


Could you add an option to the connection manager to set this?

Comments (3)

photo
1

Hi,

You should definitely be able to connect without username/password - a lot of our test databases don't have authentication either.

Make sure you have the SCRAM-SHA-1 Authentication checkbox unchecked - only if it is checked do we insist on the username/password; see below.

Hopefully that will fix your issue, but if not please let me know.

Thanks for trying dbKoda!

Guy

6617ab106762b4f81b032dc827ddec4c

photo
1

I had those options unchecked, and got an Authorization Failed error. The Host isn't a localhost though. I had thought it might have been related to using a Proxy, but when I edit the json, it worked.

photo
1

Hey Tony,

We are preparing a hotfix that will hopefully address your issue. Hopefully we will post it tomorrow or early next week.

Thanks,

Guy