Using mongo client from docker container

Vladimir Garvardt shared this question 2 months ago
Need Answer

I do not have locally installed mongo and I run most of the DBs clients apps in containers, e.g. redis-cli, mongo, psql, etc. I tried to set Mongo Path to the following value "docker run mongo mongo" in bdKoda but it fails with the following error:


Failed to update config: {"config.mongoCmd":"\u001b[31mCommand failed: \"docker run mongo mongo\" --version\n/bin/sh: docker run mongo mongo: command not found\n\u001b[39m"}


And here is what I get when I run it in the shell:


$ docker run mongo mongo --version

MongoDB shell version v3.6.3

git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5

OpenSSL version: OpenSSL 1.0.1t 3 May 2016

allocator: tcmalloc

modules: none

build environment:

distmod: debian81

distarch: x86_64

target_arch: x86_64


Am I using wrong value for Mongo Path or running mongo client in container is not supported at all?

Comments (3)

photo
2

Hi Vladimir,


First up thanks for trying dbKoda and providing us with some feedback.

At the moment dbKoda doesn't support running the mongo client from a container, but it's something we've been wanting to add for a while, so with your request we've got a great excuse to prioritize this work! I've added the task to our next release and I'll update this ticket once it's available for you to download :)


Kind Regards,

Mike from dbKoda.

photo
1

Thank you for the answer. Will wait for the update.

photo
1

I'm very interested in this as well! I use docker to manage many different mongo environments for multiple clients. Your client is amazing so I'll be checking back on progress for this request! Keep up the good work!